English

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 07-20-2007, 01:37 AM   #1
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default [LINUX][HARDWARE] Problemas con deteccion de placa de video

Hola a todos. Hacia muchisimo que no entraba a los foros. bueno, les comento que estuve con un problema porque no puedo jugar RegnumOnline desde linux (todavia tengo la PC que especifique en mi perfil cuando me registre por primera vez) porque mi placa de video no es soportada.

Me sale un msgbox con este texto:

"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"

La 1 no es, definitivamente.
La 3 tampoco (No sabia que habia controladores DirectX para utilizar nativamente desde sistemas GNU/Linux, los hay?)
La 2 no estoy seguro, instale los drivers de mi placa via consola de comandos, pero todavia no probe de utilizarla...

En fin, el error que me muestra por consola es este:
"xxx@xxx:~/RegnumOnline$ ./rolauncher
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual"

Voy a probar de reinstalar los drivers de mi placa de video (una GeForce FX 5500 con la que en WinXP el juego corria barbaro).

Por ultimo quiero felicitarlos por el tremendo laburo que han hecho. Los cambios desde la ultima vez que jugue mucho hasta ahora son enormes.

Bueno, estamos en contacto.
Saludos, y vere si lo soluciono para comentar que hice.

PD: Con el WINE es imposible correrlo (todavia no encontre juego que ande masomenos con el WINE).
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 01:41 AM   #2
arlick
Duke
 
arlick's Avatar
 
Join Date: Jan 2007
Posts: 3,939
arlick is a jewel in the rougharlick is a jewel in the rougharlick is a jewel in the rough
Default

Quote:
Originally Posted by phantomlord
Hola a todos. Hacia muchisimo que no entraba a los foros. bueno, les comento que estuve con un problema porque no puedo jugar RegnumOnline desde linux (todavia tengo la PC que especifique en mi perfil cuando me registre por primera vez) porque mi placa de video no es soportada.

Me sale un msgbox con este texto:

"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"

La 1 no es, definitivamente.
La 3 tampoco (No sabia que habia controladores DirectX para utilizar nativamente desde sistemas GNU/Linux, los hay?)
La 2 no estoy seguro, instale los drivers de mi placa via consola de comandos, pero todavia no probe de utilizarla...

En fin, el error que me muestra por consola es este:
"xxx@xxx:~/RegnumOnline$ ./rolauncher
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual"

Voy a probar de reinstalar los drivers de mi placa de video (una GeForce FX 5500 con la que en WinXP el juego corria barbaro).

Por ultimo quiero felicitarlos por el tremendo laburo que han hecho. Los cambios desde la ultima vez que jugue mucho hasta ahora son enormes.

Bueno, estamos en contacto.
Saludos, y vere si lo soluciono para comentar que hice.

PD: Con el WINE es imposible correrlo (todavia no encontre juego que ande masomenos con el WINE).
eso debe ser xq no tienes el 3d activado (parece).

proba a ver si te dice YES lo siguiente:

$ glxinfo | grep direct
__________________
"Nunca un científico ha quemado a un religioso por afirmar a Dios sin pruebas". Manuel Toharia
"uno empieza a darse cuenta que eso de no hacer ejercicio, comer y beber como si fuese la ultima cena y mantener la figura ya no existe...". Maryan
arlick no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 03:23 AM   #3
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default

Me da el siguiente error:

"leandro@leandro-desktop:~$ glxinfo | grep direct
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0"."

Esta es la salida del comando: "glxinfo | grep direct".

Voy a ver las opciones para ver si es que no tengo aceleracion 3D activada.

Saludos, y gracias.
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 05:45 AM   #4
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default Problema resuelto.

Solucionado; bueno, hice lo siguiente:

Fui a la parte de Soporte para Linux, vi el primer post que hay, me baje los drivers para Unix desde la pagina de Nvidia.

Estoy bajo Ubuntu 7.04, toque CTR+ALT+F6 entre enmodo de linea de comandos, me identifique como root, y puse lo siguiente:

/etc/init.d/gdm stop

entonces ejecutas el comando

sh path/to/archivoRunProvistoPorNVIDIA.run

luego de la ejecucion volves al modo grafico haciendo

/etc/init.d/gdm start

Eso es todo. Ami me funciono.

Saludos!
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 09:34 AM   #5
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Quote:
Originally Posted by phantomlord
Solucionado; bueno, hice lo siguiente:

Fui a la parte de Soporte para Linux, vi el primer post que hay, me baje los drivers para Unix desde la pagina de Nvidia.

Estoy bajo Ubuntu 7.04, toque CTR+ALT+F6 entre enmodo de linea de comandos, me identifique como root, y puse lo siguiente:

/etc/init.d/gdm stop

entonces ejecutas el comando

sh path/to/archivoRunProvistoPorNVIDIA.run

luego de la ejecucion volves al modo grafico haciendo

/etc/init.d/gdm start

Eso es todo. Ami me funciono.

Saludos!
sos nuevo con GNU/linux no? o sea, no tenias instalados los drivers de nvidia y como los nv no soportan un carajo ni siquiera carga el modulo GLX

PD: para cualquier problema en GNU/linux pasate por la seccion dedicada a eso
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 08:20 PM   #6
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default

Hola; Si soy nuevisimo con GNU/Linux. Me podes explicar cual seria la diferencia entre los nvidia y los nv?...

Si son lo mismo, que drivers deberia instalar entonces si ninguno de los dos soporta un 'carajo' ?

Si son diferentes, teoricamente tengo los nvidia, no los nv. ¿Que tienen de bueno? ¿Que tienen de malo? ¿Alguna alternativa?.

Estuve ayer hasta las 4AM intentando solucionar un problema de drivers para una NVidia GeForce 6600 que esta en la PC de mi hermano. Y lo solucioe masomenos que digamos....porque hoy a la mañana prendi las 2 pcs y ninguna entro a modo grafico directamente.

Tenia que hacer /etc/init.d/gdm restart para que se vea algo.

¿Alguna idea al respecto?

Sobre lo de la seccion, disculpa, no preste atencion cuando abri el Thread, no volvera a suceder.

Saludos y muchas gracias.
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 08:24 PM   #7
arlick
Duke
 
arlick's Avatar
 
Join Date: Jan 2007
Posts: 3,939
arlick is a jewel in the rougharlick is a jewel in the rougharlick is a jewel in the rough
Default

Quote:
Originally Posted by phantomlord
Tenia que hacer /etc/init.d/gdm restart para que se vea algo.
:S, un poco raro... lo pongo directamente en vez de andar con rodeos.

abre el archivo /etc/inittab

asegurate de que tenga esta linea asi

id:5:initdefault:

es la primera que está sin el simbolo "#" delante.

debe haber un 5, no un 3 ni otra cosa.
__________________
"Nunca un científico ha quemado a un religioso por afirmar a Dios sin pruebas". Manuel Toharia
"uno empieza a darse cuenta que eso de no hacer ejercicio, comer y beber como si fuese la ultima cena y mantener la figura ya no existe...". Maryan
arlick no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 10:53 PM   #8
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Quote:
Originally Posted by arlick
:S, un poco raro... lo pongo directamente en vez de andar con rodeos.

abre el archivo /etc/inittab

asegurate de que tenga esta linea asi

id:5:initdefault:

es la primera que está sin el simbolo "#" delante.

debe haber un 5, no un 3 ni otra cosa.
Arlick, eso es yerba de ubuntu que carga una parte del driver de nvidia que es "libre" y le falta el otro pedazo, cuando cargas los propietarios tenes conflictos con ese "pedaso" "libre" , hay muchos tutos en google sobre como arreglarlo y que te quede pipi cucu, una forma facil de hacerlo es hacer un script que metes en el rc.local (si , el que esta suelto en /etc/) y copias el /etc/init.d/gdm o otra carpeta como ser /gdm/ y en el rc.local pones estas lineas
#lineas a poner
rmmod nvidia
seep 2
/gdm/gdm start
#listo
con eso anda, hay formas mas bonitas y correctas de hacerlo, pero eso anda y es una solucion simple, la otra es editar los modules que carga al iniciar el sistema
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 07-21-2007, 12:19 PM   #9
arlick
Duke
 
arlick's Avatar
 
Join Date: Jan 2007
Posts: 3,939
arlick is a jewel in the rougharlick is a jewel in the rougharlick is a jewel in the rough
Default

Quote:
Originally Posted by sunos
Arlick, eso es yerba de ubuntu que carga una parte del driver de nvidia que es "libre" y le falta el otro pedazo, cuando cargas los propietarios tenes conflictos con ese "pedaso" "libre" , hay muchos tutos en google sobre como arreglarlo y que te quede pipi cucu, una forma facil de hacerlo es hacer un script que metes en el rc.local (si , el que esta suelto en /etc/) y copias el /etc/init.d/gdm o otra carpeta como ser /gdm/ y en el rc.local pones estas lineas
#lineas a poner
rmmod nvidia
seep 2
/gdm/gdm start
#listo
con eso anda, hay formas mas bonitas y correctas de hacerlo, pero eso anda y es una solucion simple, la otra es editar los modules que carga al iniciar el sistema
cada dia me doy cuenta de lo diferentes que son suse u ubuntu...
nose a me bastaría con cambiar el nivel del init...
"no te acostarás sin saber algo más"
__________________
"Nunca un científico ha quemado a un religioso por afirmar a Dios sin pruebas". Manuel Toharia
"uno empieza a darse cuenta que eso de no hacer ejercicio, comer y beber como si fuese la ultima cena y mantener la figura ya no existe...". Maryan
arlick no ha iniciado sesión   Reply With Quote
Old 07-21-2007, 12:25 PM   #10
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Quote:
Originally Posted by arlick
cada dia me doy cuenta de lo diferentes que son suse u ubuntu...
nose a me bastaría con cambiar el nivel del init...
"no te acostarás sin saber algo más"
para que cambiar el nivel del init? el problema que da ubuntu es que tiene una forma muy pedorra de hacer las cosas, que sentido tiene cargar una parte de un modulo que no sirve para nada si la parte privativa? o.0 no te sirve ni para aceleracion 2d, lo ponen porq tienen ganas de joder >.<
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Reply

Tags
linux opengl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 06:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved