English
This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 07-20-2007, 01:37 AM   #1
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default [LINUX][HARDWARE] Problemas con deteccion de placa de video

Hola a todos. Hacia muchisimo que no entraba a los foros. bueno, les comento que estuve con un problema porque no puedo jugar RegnumOnline desde linux (todavia tengo la PC que especifique en mi perfil cuando me registre por primera vez) porque mi placa de video no es soportada.

Me sale un msgbox con este texto:

"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"

La 1 no es, definitivamente.
La 3 tampoco (No sabia que habia controladores DirectX para utilizar nativamente desde sistemas GNU/Linux, los hay?)
La 2 no estoy seguro, instale los drivers de mi placa via consola de comandos, pero todavia no probe de utilizarla...

En fin, el error que me muestra por consola es este:
"xxx@xxx:~/RegnumOnline$ ./rolauncher
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual"

Voy a probar de reinstalar los drivers de mi placa de video (una GeForce FX 5500 con la que en WinXP el juego corria barbaro).

Por ultimo quiero felicitarlos por el tremendo laburo que han hecho. Los cambios desde la ultima vez que jugue mucho hasta ahora son enormes.

Bueno, estamos en contacto.
Saludos, y vere si lo soluciono para comentar que hice.

PD: Con el WINE es imposible correrlo (todavia no encontre juego que ande masomenos con el WINE).
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 01:41 AM   #2
arlick
Duke
 
arlick's Avatar
 
Join Date: Jan 2007
Posts: 3,939
arlick is a jewel in the rougharlick is a jewel in the rougharlick is a jewel in the rough
Default

Quote:
Originally Posted by phantomlord
Hola a todos. Hacia muchisimo que no entraba a los foros. bueno, les comento que estuve con un problema porque no puedo jugar RegnumOnline desde linux (todavia tengo la PC que especifique en mi perfil cuando me registre por primera vez) porque mi placa de video no es soportada.

Me sale un msgbox con este texto:

"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"

La 1 no es, definitivamente.
La 3 tampoco (No sabia que habia controladores DirectX para utilizar nativamente desde sistemas GNU/Linux, los hay?)
La 2 no estoy seguro, instale los drivers de mi placa via consola de comandos, pero todavia no probe de utilizarla...

En fin, el error que me muestra por consola es este:
"xxx@xxx:~/RegnumOnline$ ./rolauncher
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual"

Voy a probar de reinstalar los drivers de mi placa de video (una GeForce FX 5500 con la que en WinXP el juego corria barbaro).

Por ultimo quiero felicitarlos por el tremendo laburo que han hecho. Los cambios desde la ultima vez que jugue mucho hasta ahora son enormes.

Bueno, estamos en contacto.
Saludos, y vere si lo soluciono para comentar que hice.

PD: Con el WINE es imposible correrlo (todavia no encontre juego que ande masomenos con el WINE).
eso debe ser xq no tienes el 3d activado (parece).

proba a ver si te dice YES lo siguiente:

$ glxinfo | grep direct
__________________
"Nunca un científico ha quemado a un religioso por afirmar a Dios sin pruebas". Manuel Toharia
"uno empieza a darse cuenta que eso de no hacer ejercicio, comer y beber como si fuese la ultima cena y mantener la figura ya no existe...". Maryan
arlick no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 03:23 AM   #3
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default

Me da el siguiente error:

"leandro@leandro-desktop:~$ glxinfo | grep direct
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0".
Xlib: extension "GLX" missing on display ":0.0"."

Esta es la salida del comando: "glxinfo | grep direct".

Voy a ver las opciones para ver si es que no tengo aceleracion 3D activada.

Saludos, y gracias.
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 05:45 AM   #4
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default Problema resuelto.

Solucionado; bueno, hice lo siguiente:

Fui a la parte de Soporte para Linux, vi el primer post que hay, me baje los drivers para Unix desde la pagina de Nvidia.

Estoy bajo Ubuntu 7.04, toque CTR+ALT+F6 entre enmodo de linea de comandos, me identifique como root, y puse lo siguiente:

/etc/init.d/gdm stop

entonces ejecutas el comando

sh path/to/archivoRunProvistoPorNVIDIA.run

luego de la ejecucion volves al modo grafico haciendo

/etc/init.d/gdm start

Eso es todo. Ami me funciono.

Saludos!
phantomlord no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 09:34 AM   #5
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Quote:
Originally Posted by phantomlord
Solucionado; bueno, hice lo siguiente:

Fui a la parte de Soporte para Linux, vi el primer post que hay, me baje los drivers para Unix desde la pagina de Nvidia.

Estoy bajo Ubuntu 7.04, toque CTR+ALT+F6 entre enmodo de linea de comandos, me identifique como root, y puse lo siguiente:

/etc/init.d/gdm stop

entonces ejecutas el comando

sh path/to/archivoRunProvistoPorNVIDIA.run

luego de la ejecucion volves al modo grafico haciendo

/etc/init.d/gdm start

Eso es todo. Ami me funciono.

Saludos!
sos nuevo con GNU/linux no? o sea, no tenias instalados los drivers de nvidia y como los nv no soportan un carajo ni siquiera carga el modulo GLX

PD: para cualquier problema en GNU/linux pasate por la seccion dedicada a eso
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 07-20-2007, 08:20 PM   #6
phantomlord
Banned
 
Join Date: Mar 2006
Posts: 6
phantomlord is on a distinguished road
Default

Hola; Si soy nuevisimo con GNU/Linux. Me podes explicar cual seria la diferencia entre los nvidia y los nv?...

Si son lo mismo, que drivers deberia instalar entonces si ninguno de los dos soporta un 'carajo' ?

Si son diferentes, teoricamente tengo los nvidia, no los nv. ¿Que tienen de bueno? ¿Que tienen de malo? ¿Alguna alternativa?.

Estuve ayer hasta las 4AM intentando solucionar un problema de drivers para una NVidia GeForce 6600 que esta en la PC de mi hermano. Y lo solucioe masomenos que digamos....porque hoy a la mañana prendi las 2 pcs y ninguna entro a modo grafico directamente.

Tenia que hacer /etc/init.d/gdm restart para que se vea algo.

¿Alguna idea al respecto?

Sobre lo de la seccion, disculpa, no preste atencion cuando abri el Thread, no volvera a suceder.

Saludos y muchas gracias.
phantomlord no ha iniciado sesión   Reply With Quote
Old 02-23-2009, 09:48 PM   #7
Jandre
Pledge
 
Jandre's Avatar
 
Join Date: Nov 2008
Location: Si cierro los ojos, nadie me encuentra
Posts: 10
Jandre is on a distinguished road
Default El juego se cierra

Compañeros, buena tarde.

Tengo un par de meses de jugar al RO en el win, y el dia de hoy decidi instalarlo en ubuntu 8.04. Al principio no logro cargar el juego, por eso de la tarjeta grafica no soportada, pero siguiendo las intruscciones que encontre aqui para las tarjetas Intel, se soluciono, con el driconf.

Ya pude entrar y loguearme, sincronice recursos y ajuste la configuración de pantalla, el problema es que cuando termina el video de introducción, el juego se cierra. Ya desactive los efectos del compiz, pero nada. Si activo la opción de "Forzar modo seguro" el juego se cierra aun antes de presentar el video de introducción.

Solamente una vez logre llegar a la pantalla de "Buscando pjs disponibles" pero ahi se quedo, se cerro inmediatamente.

No se que podra hacer, me pregunto si a alguno de ustedes le paso esto, para que me oriente en la solución.

Saludos!
__________________
..."Aunque todos los expertos del mundo esten de acuerdo, bien pueden estar equivocados" Bertrand Rusell...
Jandre no ha iniciado sesión   Reply With Quote
Old 02-23-2009, 11:11 PM   #8
pescaupintau
Marquis
 
pescaupintau's Avatar
 
Join Date: Oct 2006
Location: no se pudo establecar conexión con el servidor
Posts: 2,057
pescaupintau is a jewel in the roughpescaupintau is a jewel in the roughpescaupintau is a jewel in the rough
Default

fijate en los log (crash_bactrace_algo se llaman) si hay algún mensaje interesante y/o dejalo aquí (a mi normalmente esos archivos no me dicen nada, pero por ahí surak los entiende)
__________________
in theCopyleft—all rights reversed
pescaupintau no ha iniciado sesión   Reply With Quote
Old 08-11-2011, 08:04 PM   #9
Kistgard531
Pledge
 
Join Date: Jul 2009
Posts: 3
Kistgard531 is on a distinguished road
Default Placa de video no soportada

Quote:
"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"
Buenas, tengo ese problema al iniciar REGNUM.
Estoy en Ubuntu 11.04. Ejecuté el comando que posteó arlick unas paginas atras y éste es el resultado:

Code:
Informe generado el día 08/11/11
++++++CPU+++++
Modelo:
 AMD Athlon(tm) Processor TF-20
MHz:
 1600.000
Cache:
 512 KB

++++++Distro+++++
Kernel: Linux pedro-M7x0K 2.6.38-10-generic #46-Ubuntu SMP Tue Jun 28 15:05:41 UTC 2011 i686 athlon i386 GNU/Linux
Arquitectura: i686
Num. Ver..: squeeze/sid
Carga & uptime: 16:32:24 up 19 min, 2 users, load average: 0.41, 0.51, 0.50
Beryl: pedro 1394 7.7 3.0 190040 54128 ? Sl 16:13 1:29 compiz pedro 1649 0.0 0.0 1912 488 ? Ss 16:13 0:00 /bin/sh -c /usr/bin/compiz-decorator Beryl Compiz ejecutándose


++++++Placa de video+++++
Hardware: 01:05.0 VGA compatible controller: ATI Technologies Inc RS690M [Radeon X1200 Series]
Aceleracion (Direct Rendering): Sin info
OpenGL:
Sin info
Extensiones S3TC: No habilitadas

++++++Xorg.conf++++++
Load: No se detectan secciones Load

Drivers: No se detectaron drivers

++++++RAM+++++
Memoria total:         1800188 kB
Memoria libre:          408104 kB

++++++sensores+++++
No hay sensores

++++++HDD+++++
S.ficheros            Tam.  Usado Disp. % Uso Montado en
/dev/sda1             292G   66G  212G  24% /
none                  873M  704K  872M   1% /dev
none                  879M  680K  879M   1% /dev/shm
none                  879M  220K  879M   1% /var/run
none                  879M     0  879M   0% /var/lock

++++++Log de Xorg+++++
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    25.626] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[    25.626] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
[    25.626] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[    25.626] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
[    25.626] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[    25.697] (WW) Warning, couldn't open module fglrx
[    25.697] (EE) Failed to load module "fglrx" (module does not exist, 0)
[    25.726] (WW) Falling back to old probe method for vesa
[    25.726] (WW) Falling back to old probe method for fbdev
Espero que me ayuden. Saludos.
Kistgard531 no ha iniciado sesión   Reply With Quote
Old 08-12-2011, 02:50 AM   #10
andres81
Count
 
Join Date: Sep 2008
Posts: 1,690
andres81 is on a distinguished road
Default

Code:
"Placa de video no soportada!

Hay tres posibles causas de este error:
1) Su placa de video es muy vieja.
2) No tiene instalados los ultimos controladores disponibles.
3) No tiene instalada la ultima version de DirectX"
No existe DirectX para Linux, deberían arreglar ese mensaje de error
andres81 no ha iniciado sesión   Reply With Quote
Reply

Tags
linux opengl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:20 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved