English
This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 04-07-2009, 04:33 AM   #21
ginTONYc
Apprentice
 
ginTONYc's Avatar
 
Join Date: Mar 2006
Posts: 63
ginTONYc is on a distinguished road
Default

La respuesta es SI , lo puedo ver.

Cuándo ejecuto:

antonio@antonio-desktop:~$ chmod +x NVIDIA-Linux-x86_64-180.44-pkg2.run
chmod: no se puede acceder a «NVIDIA-Linux-x86_64-180.44-pkg2.run»: No existe el fichero ó directorio
antonio@antonio-desktop:~$
-----------------------------------------------------------------------------------------------------------
SI ejecuto (cómo si no lo pudiera ver):

antonio@antonio-desktop:~$ find ~ -name NVIDIA-Linux-x86_64-180.44-pkg2.run
/home/antonio/Escritorio/NVIDIA-Linux-x86_64-180.44-pkg2.run
antonio@antonio-desktop:~$
-----------------------------------------------------------------------------------------------------------

Seguí intentando y cambié por lo siguiente, (ya que supuse que tal vez no reconocía Desktop cómo Escritorio, aunque sea lo mismo):
antonio@antonio-desktop:~$ sudo sh Escritorio/NVIDIA-Linux-x86_64-180.44-pkg2.run

Me abre una ventana de Nvidia (al fin), pero:

ERROR: You appear to be running an X server; please exit X before
installing. For further details, please see the section INSTALLING
THE NVIDIA DRIVER in the README available on the Linux driver
download page at www.nvidia.com.

OK
-----------------------------------------------------------------------------------------------------------
Es todo por ahora. Estoy contento, siento que avanzamos !

Saludos

PS: estuve buscando algún listado de los comandos más comunes en linux, ya que hasta ahora lo único que hago es copiar y pegar. Me pueden recomendar alguno básico?
__________________
Tuvok

Last edited by ginTONYc; 04-07-2009 at 05:03 AM.
ginTONYc no ha iniciado sesión   Reply With Quote
Old 04-07-2009, 12:51 PM   #22
pescaupintau
Marquis
 
pescaupintau's Avatar
 
Join Date: Oct 2006
Location: no se pudo establecar conexión con el servidor
Posts: 2,057
pescaupintau is a jewel in the roughpescaupintau is a jewel in the roughpescaupintau is a jewel in the rough
Default

Code:
sudo /etc/init.d/gdm stop
entonces te sale una linda pantalla de solo texto. Entrás con tu usuario y clave y hacé lo que te funcionó al último
__________________
in theCopyleft—all rights reversed
pescaupintau no ha iniciado sesión   Reply With Quote
Old 04-07-2009, 01:53 PM   #23
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

Esperá, primero que pruebe con lo siguiente:

En una consola hacé "sudo nvidia-settings"
En "X Screen 0" vas a "OpenGL Settings" y movés la barra a "High Performance". Si ya está ahí, movela a "Performance". Algunos drivers en el pasado tenían problemas con esto, y vale la pena probar.
En el launcher tratá de bajar la calidad del agua al mínimo. También probá desactivando los efectos de partícula.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 04-07-2009, 02:27 PM   #24
pescaupintau
Marquis
 
pescaupintau's Avatar
 
Join Date: Oct 2006
Location: no se pudo establecar conexión con el servidor
Posts: 2,057
pescaupintau is a jewel in the roughpescaupintau is a jewel in the roughpescaupintau is a jewel in the rough
Default

Quote:
Originally Posted by Xephandor
Esperá, primero que pruebe con lo siguiente:

En una consola hacé "sudo nvidia-settings"
En "X Screen 0" vas a "OpenGL Settings" y movés la barra a "High Performance". Si ya está ahí, movela a "Performance". Algunos drivers en el pasado tenían problemas con esto, y vale la pena probar.
En el launcher tratá de bajar la calidad del agua al mínimo. También probá desactivando los efectos de partícula.
yo lo intenté, y no pasaba nada.
__________________
in theCopyleft—all rights reversed
pescaupintau no ha iniciado sesión   Reply With Quote
Old 04-08-2009, 08:21 AM   #25
ginTONYc
Apprentice
 
ginTONYc's Avatar
 
Join Date: Mar 2006
Posts: 63
ginTONYc is on a distinguished road
Default

Quote:
Originally Posted by Xephandor View Post
Esperá, primero que pruebe con lo siguiente:

En una consola hacé "sudo nvidia-settings"
En "X Screen 0" vas a "OpenGL Settings" y movés la barra a "High Performance". Si ya está ahí, movela a "Performance". Algunos drivers en el pasado tenían problemas con esto, y vale la pena probar.
En el launcher tratá de bajar la calidad del agua al mínimo. También probá desactivando los efectos de partícula.
Primero hice lo que me aconsejó Xeph, ya que era lo más fácil:

antonio@antonio-desktop:~$ sudo nvidia-settings
[sudo] password for antonio:
sudo: nvidia-settings: command not found
antonio@antonio-desktop:~$

Después lo que me dijo Pescau:
Eso no lo puedo copiar, ya que por la pantalla negra (sudo /etc/init.d/gdm stop) no sabía cómo hacerlo, asi que les explico:

Escribió varios renglones de..... vaya a saber uno que decían.

Probé dos formas:


sudo sh Escritorio/NVIDIA-Linux-x86_64-180.44-pkg2.run

antonio@antonio-desktop:~$ sudo sh Escritorio/NVIDIA-Linux-x86_64-180.44-pkg2.run <----------------------------------------------------- estuve un buen rato para encontrar "~"



En ambas se quedó el cursor titilando sin hacer nada. (Tuve que reiniciar la PC, porque no podía salir de ahi).






Segui intentando (para ver si podía volver a UBUNTU) y presioné Alt+F2 y apareciò:

antonio@antonio-desktop:~$

Escribí:
sudo sh Escritorio/NVIDIA-Linux-x86_64-180.44-pkg2.run (insistente yo????????) XD

Apareció una ventana de NVIDIA:

Please read following license.......
Acepté.

Otra ventana, la cual transcribo:

No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from the Nvidia ftp site (ftp://download.nvidia.com) ?

Yes

Otra ventana:

No matching precompiled kernel interface was found on the Nvidia ftp site; this means that the installer willneed to compile a kernel interface for your kernel.

OK

Otra ventana:
ERROR: you do not have libc header files installed on your system. Please install your distribution´s libc development package.

OK

Otra ventana:

ERROR: instalation has failed. Please see the file '/var/log/nvidia-installer.log' for details.
You may find suggestions on fixing installation problems in the readme available on the linux driver download page at www.nvidia.com

OK

Les agradezco por su paciencia.....

Saludos
__________________
Tuvok

Last edited by ginTONYc; 04-08-2009 at 09:57 AM.
ginTONYc no ha iniciado sesión   Reply With Quote
Old 04-08-2009, 12:32 PM   #26
pescaupintau
Marquis
 
pescaupintau's Avatar
 
Join Date: Oct 2006
Location: no se pudo establecar conexión con el servidor
Posts: 2,057
pescaupintau is a jewel in the roughpescaupintau is a jewel in the roughpescaupintau is a jewel in the rough
Default

sudo apt-get install build-essentials
o algo asi, no recuerdo bien el nombre del paquete. Además seguramente necesites los headers del kernel, mierda este win me puso cualquier teclado menos el que tengo, no encuentro el simbolo de pesos. xeph-arlick-sunos le indican como? ₧₧₧₧ o sea, cualquiera, esa moneda esta obsoleta no?
__________________
in theCopyleft—all rights reversed
pescaupintau no ha iniciado sesión   Reply With Quote
Old 04-08-2009, 08:45 PM   #27
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

ejecutá textualmente esto, desde la consola o modo gráfico:

sudo apt-get update
sudo apr-get install build-essential linux-headers-$(uname -r) binutils


Luego hacés los pasos anteriores. Me parece que voy a armar una pequeña guía de instalación para los drivers oficiales privativos.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 04-08-2009, 11:29 PM   #28
ginTONYc
Apprentice
 
ginTONYc's Avatar
 
Join Date: Mar 2006
Posts: 63
ginTONYc is on a distinguished road
Default

antonio@antonio-desktop:~$ sudo apt-get update
[sudo] password for antonio:
.................................................. ..........................
Descargados 1158kB en 17s (66,8kB/s)
Leyendo lista de paquetes... Hecho
antonio@antonio-desktop:~$ sudo apr-get install build-essential linux-headers-$(uname -r) binutils
sudo: apr-get: command not found
antonio@antonio-desktop:~$


Creo que algo me falló. No puse todo lo que actualizó, porque era largo. Lo tengo guardado por si necesitan verlo.

Saludos

Edito: cambié sudo apr-get install build-essential linux-headers-$(uname -r) binutils
por sudo apt-get install build-essential linux-headers-$(uname -r) binutils (porque la instrucción anterior decía apt, en vez de apr y supuse que tal vez había un error de tipeo) Anduvo, aunque espero no haberme mandado una c*gada.

Ahora continuo los pasos y posteo.
__________________
Tuvok

Last edited by ginTONYc; 04-08-2009 at 11:56 PM.
ginTONYc no ha iniciado sesión   Reply With Quote
Old 04-09-2009, 12:07 AM   #29
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

Sí, era un error de tipeo... No me pueden pasar estas cosas. >_<

Muy bien Tony...
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 04-09-2009, 12:37 AM   #30
ginTONYc
Apprentice
 
ginTONYc's Avatar
 
Join Date: Mar 2006
Posts: 63
ginTONYc is on a distinguished road
Default



Arrancó al fin. Después de que acepté (vi algo del kernel) volvió a la pantalla negra y reinicié cómo siempre.
Ahora no me reconoce el monitor ni los controladores de mi placa de video. Estoy viendo todo en 800x600. Cuándo intento entrar a RO , me dice que mi placa de video es muy vieja.

Mi monitor es un ViewSonic VA2216w (Wide-22").

Estoy desesperado !!!!!

Saludos
__________________
Tuvok
ginTONYc no ha iniciado sesión   Reply With Quote
Reply

Tags
linux graphic glitch, linux nvidia

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved