English
This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 06-05-2008, 10:01 PM   #1
dani-o
Duke
 
dani-o's Avatar
 
Join Date: Feb 2007
Location: gracias kailer por los -38 de karma ¬¬ ... De nada. Kailer
Posts: 3,917
dani-o will become famous soon enoughdani-o will become famous soon enough
Default Instalador en Linux, ¿32 o 64 bits?

hola q tal recie instle ubuntu en mi pc, y queria instalar el juego, la cosa es asi

mi procesador es un athlon 64 dual core, pero no se si mi ubuntu es 32 o 64 esto influye?

o sea me tengo q bajar el instalador teneindo en cuenta el micro o el operativo?

q pasa si me bajo el de 32 bit y mi procesador es de 64?

q pasa si me bajo el de 64 bit y mi operativo es de 32?

sorry!! gamemod! movelo a la seccion de linux plis =)
__________________

if you can shot from a 40mts range, and actually move faster than a class that can only attack you from 1.5 mts... how in the world are those guys going to be able even reach you? -chilko-
dani-o no ha iniciado sesión   Reply With Quote
Old 06-05-2008, 10:40 PM   #2
gamemod
NGD·Studios
 
gamemod's Avatar
 
Join Date: May 2008
Location: NGD Studios
Posts: 508
gamemod will become famous soon enough
Default

Hola dani-o,

Para saber si tu distro es 32 o 64 bit poné esto en una terminal:

Code:
uname -m
Si te dice i386 o i686 es 32 bit, y si te dice x86_64 es 64 bit.

No pasa nada si usas una distro 32 bit en un procesador de 64 bit, y hasta te lo recomiendo si es que recién empezas con Linux, para no tener problemas a la hora de compilar y configurar.

Luego, segun tu distro, te bajás el instalador de Regnum correspondiente.

Saludos.
__________________
gamemod - ngd Studios
gamemod no ha iniciado sesión   Reply With Quote
Old 06-05-2008, 10:59 PM   #3
dani-o
Duke
 
dani-o's Avatar
 
Join Date: Feb 2007
Location: gracias kailer por los -38 de karma ¬¬ ... De nada. Kailer
Posts: 3,917
dani-o will become famous soon enoughdani-o will become famous soon enough
Default

gracias gameGod =) mi distro (ya hasta uso la jerga ^^) es 64 y ya me estoy bajando el instalador.

lo malo es q no consigo drivers para el video, seguramente no pueda correr el game, ahora tengo lo maxima en 800x600 =(

mi placa es una biostar con chip nvidia ge force 405 nforce 6100, si tenes alguna noticia de un driver o algo te agradecere
__________________

if you can shot from a 40mts range, and actually move faster than a class that can only attack you from 1.5 mts... how in the world are those guys going to be able even reach you? -chilko-
dani-o no ha iniciado sesión   Reply With Quote
Old 06-05-2008, 11:22 PM   #4
gamemod
NGD·Studios
 
gamemod's Avatar
 
Join Date: May 2008
Location: NGD Studios
Posts: 508
gamemod will become famous soon enough
Default

Quote:
Originally Posted by dani-o
gracias gameGod =) mi distro (ya hasta uso la jerga ^^) es 64 y ya me estoy bajando el instalador.

lo malo es q no consigo drivers para el video, seguramente no pueda correr el game, ahora tengo lo maxima en 800x600 =(

mi placa es una biostar con chip nvidia ge force 405 nforce 6100, si tenes alguna noticia de un driver o algo te agradecere
Si usas Ubuntu, podés instalar el driver de nVidia mediante el Envy.

Para instalarlo, abrí una terminal y tipeá estas líneas.

Code:
wget http://albertomilone.com/ubuntu/nvidia/scripts/envy_0.9.6-0ubuntu2_all.deb
sudo dpkg -i  envy_0.9.6-0ubuntu2_all.deb
Luego resolvés las dependencias.

Code:
sudo apt-get -f install
Luego podés ejecutarlo desde el menu de aplicaciones o desde la terminal:

Code:
su
envy -g
Luego seleccionás que tipo de placa de video tenés y voilà.

Saludos.
__________________
gamemod - ngd Studios
gamemod no ha iniciado sesión   Reply With Quote
Old 06-06-2008, 12:31 AM   #5
dani-o
Duke
 
dani-o's Avatar
 
Join Date: Feb 2007
Location: gracias kailer por los -38 de karma ¬¬ ... De nada. Kailer
Posts: 3,917
dani-o will become famous soon enoughdani-o will become famous soon enough
Default

me da un error me tira un log, y el log dice esto Y_Y

Quote:
Originally Posted by envy
ENVY ERROR: Your Operative System does not seem to be supported by Envy
__________________

if you can shot from a 40mts range, and actually move faster than a class that can only attack you from 1.5 mts... how in the world are those guys going to be able even reach you? -chilko-
dani-o no ha iniciado sesión   Reply With Quote
Old 06-06-2008, 12:49 AM   #6
gamemod
NGD·Studios
 
gamemod's Avatar
 
Join Date: May 2008
Location: NGD Studios
Posts: 508
gamemod will become famous soon enough
Default

Quote:
Originally Posted by dani-o
me da un error me tira un log, y el log dice esto Y_Y
Bueno, procedemos a instalarlo de la manera más ortodoxa.

Bajate este driver:

http://us.download.nvidia.com/XFree8...14.05-pkg2.run

Supongamos que el archivo queda en:

Code:
/home/usuario/NVIDIA-Linux-x86_64-173.14.05-pkg2.run
Abrí una consola con Ctrl + Alt + F2 y logueate como root.

Hay que detener el modo gráfico:

Code:
/etc/init.d/gdm stop
Vamos al directorio donde se encuentra el driver:

Code:
cd /home/usuario
Ejecutamos el installer:

Code:
sudo sh NVIDIA-Linux-x86_64-173.14.05-pkg2.run
Cerca del final de la instalación te va a pedir si querés que configure el archivo xorg.conf, y lo aceptaś.

Y luego, finalizado este proceso, reiniciamos:

Code:
reboot
Saludos.
__________________
gamemod - ngd Studios
gamemod no ha iniciado sesión   Reply With Quote
Old 06-06-2008, 01:32 AM   #7
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

La solución de nVidia nunca falla, pero vas a tener que repetir el proceso cada vez que cambies de kernel. Si estás en Ubuntu (creo que estás usando ese), podés activar el módulo desde el "gestor de controladores restringidos". Éste se encuentra en Sistemas > Administración > Gestor de controladores restringidos.

La segunda opción es usar apt-get. Es exactamente lo mismo que lo anterior, la única diferencia es que este método es por consola. Para eso hacé:

Code:
sudo apt-get install nvidia-glx nvidia-settings
Dpkg resuelve las dependencias solo. No hay problema en esto
PD: El mismo procedimiento se puede utilizar para toda distro basada en Debian o con sistema dpkg (apt-get).
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Old 06-07-2008, 08:22 AM   #8
cristian85
Initiate
 
cristian85's Avatar
 
Join Date: Jan 2008
Posts: 111
cristian85 is on a distinguished road
Default

Pues en ubuntu trae un envy nuevo especial para ubuntu hardy asi que no uses el viejo que es para otras versiones. Con en gestor de controladores restringuidos te la instala correctamente. Sino creo que podes hacer lo que dice Xephandor, sin embargo si tu targeta es mas moderna tendras tendras que instalar el driver nuevo, lo puedes hacer desde synaptic para que no uses la consola. solo busca con nvidia y instala el nvidia-new-glx creo que asi se llama.

Para hacer la instalacion manual que dice gamemod es mejor ya que los driver de ndivia que trae hardy por defecto estan malos de fabrica. Asi que mejor sigue el metodo de gamemod sin embargo hay que instalar unos paquetes adicionales antes de instalar los driver. Te aconsejo que busques informacion en google para tener informacion adicional.
__________________
Cazador Negro
cristian85 no ha iniciado sesión   Reply With Quote
Old 06-07-2008, 12:09 PM   #9
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Los paquetes necesarios para poder compilar son los build-essential (o build-essentials , ahora no recuerdo el nombre exacto) ahi se instala lo necesario para poder compilar la parte del modulo de nvidia asi como cualquier otro programa (siempre y cuando tengas las dependencias :-P ) :-)
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 06-07-2008, 03:45 PM   #10
ArcticWolf
Duke
 
ArcticWolf's Avatar
 
Join Date: Nov 2006
Location: 0x00CAFE
Posts: 3,366
ArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of lightArcticWolf is a glorious beacon of light
Default

También en Etch podés utilizar el module-assistant, en caso de que instales la versión de repositorios. Es de la única forma que lo pude hacer andar, y luego preferí usar el instalador oficial.

Actualmente no puedo ayudarlos con temas de los nuevos drivers porque tuve un pequeño problema con mi 6200 NO refrigerada ¬¬

De todos modos, fíjense siempre que sus xorg.conf son actualizados después de la instalación. Ya vi muchos problemas en Ubuntu donde éste no está correctamente configurado y no se activa la aceleración por seguir usando el driver nv.
__________________
I don't have a solution, but I admire the problem.
ArcticWolf no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 04:02 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved