English
This forum is closed for posting. Please, join us in our Discord server at discord.gg/regnum. See you there!

Go Back   Champions of Regnum > Español > Soporte Técnico > Linux

Linux Problemas técnicos bajo la plataforma Linux

Reply
 
Thread Tools Display Modes
Old 01-24-2008, 03:45 AM   #1
sinsentidonirazon
Pledge
 
Join Date: Jan 2008
Posts: 10
sinsentidonirazon is on a distinguished road
Default Error de DirectX u OpenGL.

Bueno, hola a todos, soy un aficionado al RO desde ya hace rato y estoy un poco frustrado porque no me anda en mi flamante Ubuntu Gutsy 7.10. La cuestio es que da el mensaje de error de tarjeta vieja, que necesito nuevos drivers y eso (ya lo conocen). Lei los threads que hay al respecto, aplique la mayoria pero nada, me sigue dando el error. Aqui esta la info:
----------------------------------------------------------------------------------------------------
INFO
----------------------------------------------------------------------------------------------------
glxinfo | grep OpenGL

OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 945GM 20061017 x86/MMX/SSE2
OpenGL version string: 1.3 Mesa 7.0.1
OpenGL extensions:

------------------------------------------------------
glxinfo | grep direct

direct rendering: Yes

------------------------------------------------------
glxgears

4793 frames in 5.0 seconds = 958.512 FPS
4894 frames in 5.0 seconds = 978.785 FPS
4910 frames in 5.0 seconds = 981.812 FPS
4877 frames in 5.0 seconds = 975.341 FPS
4892 frames in 5.0 seconds = 978.296 FPS
4866 frames in 5.0 seconds = 973.068 FPS

------------------------------------------------------
glxinfo | grep version

server glx version string: 1.2
client glx version string: 1.4
GLX version: 1.2
OpenGL version string: 1.3 Mesa 7.0.1

----------------------------------------------------------------------------------------------------
Y AKY EL XORG
-----------------------------------------------------------------------------------------------------
# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "latam"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Monitor genérico"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Monitor "Monitor genérico"
DefaultDepth 24
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

-------------------------------------------------------------------------------------------------
NOTA
------------------------------------------------------------------------------------------------
Lo mas cerca que estuve fue con el DRIconf, logre entrar al juego pero todo se veía de mierda (en serio terrible), probé con modo seguro, poniendo todo al minimo y nada.

Les agradezco si me pueden ayudar (porfavor!!! no quiero volver a micro$oft!!)

Y otra cosa, no hay un paquete de instalacion .deb? o un repositorio para añadir?
sinsentidonirazon no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 03:57 AM   #2
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

bien, con driconf habilitas la compresion s3tc, sin eso no se puede jugar, con respecto a lo de que se ve mal ... es medio raro, proba de actualizandote a la ultima version de Mesaa ver si se te soluciona, acordate que los drivers mesa estan por ingenieria inversa en su mayoria asi que no andan al 100% con todas las graficas
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 04:42 AM   #3
sinsentidonirazon
Pledge
 
Join Date: Jan 2008
Posts: 10
sinsentidonirazon is on a distinguished road
Default

gracias por tu colaboracion, con el driconf ya tenia habilitadas las S3TC, ahora anda mejor (despues de instalar estas librerias: libdrm-dev xorg-dev) pero aun hay un pr de problemas:

No se ven los arboles (solo los troncos sin hojas ni ramas)
Muchos de los objetos se ven con parches de colores

Si alguien sabe como solucionar esto le agradezco de antemano. (ya estoy corriendo en modo seguro)
sinsentidonirazon no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 05:04 AM   #4
sinsentidonirazon
Pledge
 
Join Date: Jan 2008
Posts: 10
sinsentidonirazon is on a distinguished road
Default Añado imagenes de lo que veo

Ahi estan los screenshots
Attached Images
File Type: jpg Pantallazo.jpg (57.5 KB, 28 views)
File Type: jpg Pantallazo-1.jpg (63.5 KB, 25 views)
sinsentidonirazon no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 05:25 AM   #5
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

mm.. para usar beryl||compiz-fusion usas Xgl? o aiglx?
proba de jugar sin beryl||compiz-fusion
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 03:46 PM   #6
sinsentidonirazon
Pledge
 
Join Date: Jan 2008
Posts: 10
sinsentidonirazon is on a distinguished road
Default

bueno, como soy nuevo me toca preguntar:

No sé si tengo activado beryl/compiz
Si lo está como lo desactivo?


Gracias a todos por su ayuda, que viva linux!
sinsentidonirazon no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 03:49 PM   #7
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

Quote:
Originally Posted by sinsentidonirazon
bueno, como soy nuevo me toca preguntar:

No sé si tengo activado beryl/compiz
Si lo está como lo desactivo?


Gracias a todos por su ayuda, que viva linux!
beryl o compiz fuzion es eso que te hace temblar las ventanas, te da transparencias y el cubo del escritorio y todos esos efectos muy locos
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 06:12 PM   #8
sinsentidonirazon
Pledge
 
Join Date: Jan 2008
Posts: 10
sinsentidonirazon is on a distinguished road
Default

bueno lo que hice fue ir a

sistema/preferencias/apariencia, y desactive los efectos visuales.

resultado: sigue igual
sinsentidonirazon no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 06:48 PM   #9
SirameK
Master
 
SirameK's Avatar
 
Join Date: May 2007
Location: Vigo/ Bosch
Posts: 549
SirameK will become famous soon enough
Default

a mi me pasa exactamente lo mismo, sunos una nota, cuando consegui correr el regnum (mira que nos costo) ya me pasaba eso del fallo en las texturas, y aun no habia instalado compizfusion... que sera???
__________________
SirameK no ha iniciado sesión   Reply With Quote
Old 01-24-2008, 07:20 PM   #10
sunos
Count
 
sunos's Avatar
 
Join Date: Jan 2007
Location: Rosario
Posts: 1,440
sunos has a spectacular aura aboutsunos has a spectacular aura about
Default

alguna incompatibilidad de los drivers mesa con ciertas intrucciones que usan esas texturas en particular, quizas en una siguiente release ya este corregido, le estan metiendo muchas pilas al soporte de placas Intel
__________________
Usuario GNU/linux registrado Nº450915
"Sólo hay un problema con el sentido común: que no es demasiado común" -- Milt Bryce
sunos no ha iniciado sesión   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NGD Studios 2002-2016 © All rights reserved